Добро пожаловать, Гость
Логин: Пароль: Запомнить меня

egw+Ubuntu14.04.2lts. Послеустановочный setup
(1 чел.) (1) гость
  • Страница:
  • 1
  • 2
  • 3

ТЕМА: egw+Ubuntu14.04.2lts. Послеустановочный setup

Re: egw+Ubuntu14.04.2lts. Послеустановочный setup 4 года назад #2454

  • biox
  • Вне сайта
  • Fresh Boarder
  • Постов: 8
  • Репутация: 0
созадю базу, даю привелегии юзеру, указываю в хедер конфиг скрипте логин и пасс к базе... результат не изменен... вхожу в конфиг сетам, там предложение создать базу из под рута, попытка сделать это или речек приводит к выбросу на login page
При этом я прекрасно подключаюсь к базе как из терминала так и через phpmyadmin. db Логин и пасс в header.inc.php правильные
Изменено: 4 года назад от biox.

Re: egw+Ubuntu14.04.2lts. Послеустановочный setup 4 года назад #2455

  • biox
  • Вне сайта
  • Fresh Boarder
  • Постов: 8
  • Репутация: 0
так.... коннект к базе установлен. Теперь петрушка с выбросом на login page повторяется с установкой приложений.

Re: egw+Ubuntu14.04.2lts. Послеустановочный setup 4 года назад #2456

  • Pauli
  • Вне сайта
  • Administrator
  • Постов: 59
  • Репутация: 5
Если мы создали базу, пользователя к ней и пароль, правильно вписали их в хедер, а setup предлагает создать базу - это говорит о том что с этими учётными данными setup базу открыть не смог и полагает что её нет. Иначе он сказал бы что база доступна, а не установить ли нам все приложения (в смысле, не создать ли уже в базе таблицы под приложения).
В таких случаях я обычно использую phpmyadmin (или mysql): ввожу те самые логин и пароль что указаны в хедере и смотрю что будет.

Re: egw+Ubuntu14.04.2lts. Послеустановочный setup 4 года назад #2457

  • Pauli
  • Вне сайта
  • Administrator
  • Постов: 59
  • Репутация: 5
biox написал:
так.... коннект к базе установлен. Теперь петрушка с выбросом на login page повторяется с установкой приложений.

А вот такого быть не должно, точно. При выборе Установить все приложения она должна сморгнуть и предложить повторно проверить установку. При повторной проверке сообщить "Все приложения установлены" и предложить назначить админа, или сообщить об ошибке. Но не логин!
Неужели 1.8 в репах Ubuntu порченая? Смотреть логи Apache, там что-то может быть.
Ещё вариант: стащить архив egroupware версии 1.8 с сайта разработчиков и попробовать переписать им весь каталог установки. Мало ли что там в репах Ubuntu. Хуже от этого точно не будет, особенно теперь.
Ещё вариант: поставить ещё один, пробный, вариант сервера. С нуля. Можно в виртуалке. И посмотреть что получится если ставить вручную, не из репо. Вы говорили что сервер у вас с историей - мало ли что может расти из тьмы времён.
Изменено: 4 года назад от Pauli.

Re: egw+Ubuntu14.04.2lts. Послеустановочный setup 4 года назад #2458

  • Pauli
  • Вне сайта
  • Administrator
  • Постов: 59
  • Репутация: 5
Ещё один возможный источник проблемы - ваш браузер и/или его настройки/расширения. Что, на самом деле, мы наблюдаем, на что оно больше всего похоже? Похоже на то, что у нас неожиданно и неоправданно рвётся сеанс. После разрыва сеанса egw просто ничего не остаётся, как переспросить пароль - сеанс-то разорван! Куки браузер принимает? Хотя бы с этого конкретного адреса?
В пользу такой гипотезы может свидетельствовать появление сообщения "Ваш сеанс не может быть удостоверен."
Попробовать более другой браузер, попробовать поработать с другого рабочего места с другим антивирусом (если вообще был).

Re: egw+Ubuntu14.04.2lts. Послеустановочный setup 4 года назад #2459

  • biox
  • Вне сайта
  • Fresh Boarder
  • Постов: 8
  • Репутация: 0
Именно коннект установлен а при попытке "установки приложений" то есть создания таблиц есть то что есть. С нуля ставил, и на другой серв ставил, там то же убунту но не lts. Правда ставил всё из репов. Результат ВСЕГДА одинаковый.
Идея с "другим браузером" понравилась. Попробую.
  • Страница:
  • 1
  • 2
  • 3
Модераторы: admin, vader666
Время создания страницы: 0.23 секунд